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Windmill strengths and weaknesses

GEN

Strengths
e Highly configurable
e Cansupport a wide variety of different commons
e Tightly coupled with Gen3 services

Weaknesses

Monolithic architecture and deployment

Difficult to extend and configure

Project/Business logic embedded in the code
Inadequate support for data movement between pages
Complex development environment

DATA COMMONS



Gen3 Frontend Framework

Introducing the Gen3 Frontend Framework

Replacement for Gen3 data-portal
Address frontend limitations
Improved development experience and user experience
Updated technology stack
Enhancing:
o Custom content and applications development

o Performance
o Deployment and maintenance

GEN

DATA COMMONS




Overview

Provide functions to
access Gen3 services
Introduce concept of
Context

Analysis Tool Framework
Standardize Components
Upgraded tech. stack
Simpler custom custom

pages

Gen3 Frontend Framework

GEN

DATA COMMONS

Gen3 Application Analysis Tools } Application
Gen3 Components Content management } Frontend
Components

Analysis Tool Framework

Data Access Layer

» Framework




Context GEN
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The concept of the user’s context is a

powerful feature of the Gen3 Gen 3 Custom
Frontend Framework Explorer Page
Context provides pages and tools Page

with information about:
o  Active cohort
Selected studies

O
o Active analysis tool
o AuthN/Authz

Context is available to all pages and
analysis tools Context




Framework Technology Stack GEN
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NextJS for full-stack web applications

React as the Ul framework

Redux-toolkit and SWR NE X T.
Written in Typescript (with JavaScript compatibility)

Theming and styling with Tailwind CSS

Mantine.dev for component library

2 i
,f’” Tailwind CSS o



Framework Modules GEN
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e Framework is divided into 2 npm packages and a template
o Core module @gen3/framework
o Frontend module @gen3/frontend
o Gen3data commons web application template

e Goals:
o Reduce code complexity
o Abstract Ul interactions
o  Support customization
o Simplify deployment



Core Module: @gen3/framework GEN
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e Provides a data interface to Gen3 services  Gen3 Frontend Framework
independent of components

e Manages user's context: cohort, selected
studies, files, and analysis tools

e Allows future features: user's command
history

e Accessto Gen3 services via "hooks"

e Abstracted API calls for simplified data
retrieval

e Designed toisolate frontend
components/web service from Gen3 API
changes

Framework



Analysis Tool Framework (ATF) GEN
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e Supports the development of custom analysis tools
e Connectto:
o Gen3services
o  3rd-party APIs
o Other data sources
e Uses context to filter tools that can be applied to current data selection
e Frontend:
o Support to register apps as plugins
©  Analysis tool page



Frontend Module: @gen3/frontend GEN
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e Standard Gen3 pages: Gen3 Frontend Framework

o Discovery
o Exploration

o Data Dictionary Gens Comporens Components

O
e Theming and configuration
functions
e Gen3 components build using
mantine components
e Uses Gen3 services/data via
@gen3/framework hooks



Commons Specific Code GEN

DATA COMMONS

Commons Specific code is implemented as a functions that:

o Retrieve
o Transform
o Render

Gen3 Feature accept a function hook to override default behavior

Default hooks are implemented to provide standard behavior

Tables/charts can be customized by registering custom Cell and Chart components
Planned provide templates and Developer documentation



Discovery Page Data Hook Example GEN
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Data-portal:
e Discovery page reads data from the Gen3 Metadata Service
e Pulls data from MDS and/or Aggregate MDS
e The complexity/variety of metadata makes configuration complex
e All metadata is loaded into the client to support search

Gen3 Frontend Framework:
e Developers pass a function (e.x. hook) to discovery page to load data/transform

data
e Enables data transformation logic to be commons specific



Discovery Page Data Hook Example GEN
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Discovery
Advanced Search Search bar Key/Value Search > Data Hook Gen3 Metadata Service
Summary/
Aggregations /1 \\

M Table

Pagination

\ Data for aggregations )




Cell Renderer Example

DATA COMMONS

0
<
I

export const LinkedStudyCell = ({ Test Name Test Results Text
value: cellValue,
}. CellRenderFunctionProps<boolean>) : Element => {

const value : boolean = cellValue as boolean;
? - : =
return value ? ( (_ coviD-19 \/ COVID-19 ) NEGATIVE NEGATIVE
<Badge ; % N
AT AR o UE TR (_covip-19 )(_ covip-19 ) NEGATIVE
leftSection={<CheckCircleOutlined />} I
color="green" {_covIb19 )
>
Linked (_covip-19 )
</Badge>
) (Ccovio-19 )
<Badge leftSection={<MinusCircleOutlined />} color="primary">
Not Linked (_covip-19 )(_covip-19 ) NEGATIVE ] NEGATIVE
! </Badge> (Ccovin-19 ) NEGATIVE
H

bi (_covip-19 ) NEGATIVE

const CommonsCellRenderers :{boolean:{...}, string: {.}} = { J—
bl Ceownis)
default: WrappedStringCell,

}, (_covip-19 ) NEGATIVE

boolean: {
L1nkedStudyCell, ( COVID-19 \/} NEGATIVE
h
}; / T 3 N
(_covip-19 )(_ covip-19 ) NEGATIVE NEGATIVE
. . : P N :
export const registerDiscoveryCustomCellRenderers = () :void => { (_covip-19 )(__covip-19 ) NEGATIVE NEGATIVE

DiscoveryCellRendererFactory.registerCellRendererCatalog(CommonsCellRenderers);

b

Rows per page u 1-100f 12,159 K < >
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Common location for storing selection: My Data Library
Analysis tool plugins

Static content

Custom pages

Custom content via markdown

Context

Updated site navigation and new Ul design

508 compliant



New Design/UX

SR Open Access Data Commons

EXPLORE AND SHARE DATA

Query

The Open Access Data Commons is a scalable cloud-based platform for computation
Notebook Browser

for the health community.

Profile I

If you have any questions about access or the registration process, pleas

support@datacommons.io.

Designed for the health community, the Open Access Data Commons is
ascalable, cloud-based platform for computational discoven

Dictionary v0.3.0 | Submission v2023.04 | Portal v5.13.0

DATA COMMONS

g & = %

Discovery  Dictionary ~ Exploration  Query  Notebook Browser  Profile

Open Access Data Commons
EXPLORE AND SHARE DATA

The Open Access Data Commons is a scalable cloud-based platform for computational discovery designed

for the health community.

If you have any questions about access or the registration process, please contact

support@datacommons.io.

CONTACT HELP PLATFORM

About Us User Guides Workspaces

Contact Tutorials Dictionary
FAQ Profile

Designed for the health community, the Open Access Data Commons is
ascalable, cloud-based platform for computational discovery.

Dictionary v0.3.0 | Submission v2023.04 | Portal v5.13.0



New Design/UX

Documentation | Email Support | Cite BRH | email@emailedu @ | Logout

Biomedical Research ()

@ Link Account from External Data Resources

JCOIN Google Login

£ m ®

Discovery Workspace  Example Analysis Profile

NCI-CRDC RAS Login

0P jco e 1P erdera
Provider URL https://jco non Provider URL ttps://nci-c ommons.io
Status Expires in 15 Status Not authorized

C Refresh JCOIN Google Login ‘ ‘ © Authorize NCI-CRDC RAS Login

MIDRC NIH Login Access Clinical Data - NIH Login
1P crdcras 0P v
Provider URL hitps://nci-crdc.datacommans.io Provider URL attps://accessclinicaldata.niaid.r
Status u Status t
Authorize MIDRC NIH Login ‘ ‘ ® Authorize Access Clinical Data - NIH Login
1BDGC Google Login OADC Google Login

0P bdgc 3 0P oadc e

Provider URL https://ibdgc.da

Status

Provider URL tp ]

Status

C Refresh IBDGC Google Login

‘ ® Authorize OADC Google Login

Tutorial CANINE Google Login

IDP.

Provider URL hitp

BioDataCatalyst RAS Login

IDP Sdcat-ra:

Provider URL ttps:

Status tauthorize Status Not authorized
9 Authorize Tutorial CANINE Google Login J ‘ Authorize BioDataCatalyst RAS Login
AnVIL RAS Login
0P i
Provider URL ps: wiLio
Status uthorize

Authorize AnVIL RAS Login

GENZ

~ Current AP Keys

Create an API Key

API Key

~ Resources

requestor
dictionary_page
kayako

fence

guppy
peregrine
sheepdog

job

<< N N<N<N<N<N<N<]

jupyterhub

Status

Active

Resource

[cedar

/dictionary_page

/kayako

/mds_gateway

/orograms/open

Discovery

Browse
Data
-

Dictionary

Expiration Date

12/1/2023,12:21:26 PM

create

Exploration

access

Rows per page

DATA COMMONS

X
Query Analysis Workspace profile
Actions

read read-storage

Logout 3]



New Design/UX

Exploration Dictionary Example Analysis

@ ADMINISTRATIVE

The collection of all data related to a specific patient or case in the context of a specific

v G Nl & Tsv
.
The Medical Imaging and Data Resource Center
MIDRC) Commons dictionary has 25 nodes and
( ) Com: Y Property Type Required
454 properties.
I case_ids Array No Alist of one or more case submitter_ids associated with this data.
Case
Q t Ahuman-readable, unique identifier for a record in the metadata database. It can be
submitter_id String Yes used in place of the UUID for identifying or recalling a record (e.g., in data queries or
Search Results uploads/exports).
1 match in nodes ) )
N Ahuman-readable, unique identifier for a record in the metadata database. It can be
) ra;
10 matches in node properties projects ob yt Yes used in place of the UUID for identifying or recalling a record (e.g., in data queries or
ec
) uploads/exports).
Case
case_ids Array No Alist of one or more case submitter_ids associated with this data.
+ Administrative » Case > Type
i dicalil An entity responsible for making contributions to the resource. Examples of a
#iMedical istory, » Dataset xCases contributor String No Contributor include a person, an organization, or a service. Typically, the name of a
+ Imaging Data > Program » Type Contributor should be used to indicate the entity.
¢ DatafFile » Project > File Name The spatial or temporal topic of the resource, the spatial applicability of the
- resource, or the jurisdiction under which the resource is relevant. Spatial topic and
spatial applicability may be a named place or a location specified by its geographic
coordinates. Temporal topic may be a named period, date, or date range. A
Search Histor (ClearA jurisdiction may be a named administrative entity or a geographic place to which the
i eanall) coverage String No 4 Hi ety ora geograpmic
resource applies. Recommended best practice is to use a controlled vocabulary such
NSAID

+ Administrative » Case » Type
4 Medical History » Dataset » Cases

¢ Imaging Data > Program » Type

Core Metadata

as the Thesaurus of Geographic Names [TGN] (http-//wwuw.getty.edu/research/tools/
vocabulary/tgn/index.html). Where appropriate, named places or time periods can
be used in preference to numeric identifiers such as sets of coordinates or date
ranges.

Acollection of data files in a project.

& DataFile » Project > File Name Collection
~ 8more Aset of metadata and associated data file objects originating from single a research
> Dataset N B
Ll study, clinical trial or patient cohort.
avail_mechanism
>  Program Abroad framework of goals to be achieved. (NCIt C52647) & JSON & TSV
+ Administrative » Case » Type
i e Any specifically defined piece of work that is undertaken or attempted to meet a single
jcal History » , > Project N B
+ Medical History » Dataset » Cases rojec relirmeniNclFcaTass]
+ Imaging Data > Program » Type
> Visit Information about a specific visit for a specific case or patient. & JSON & TSV

+ DataFile » Project » File Name

v 11more

DATA COMMONS

# MEDICAL HISTORY

Information related to the condition(s) of a case within the context of a particular study



New Design/UX

DATA COMMONS

GEN3

Cases  Measurements  Imaging Studies

T CHEY)

I3 Cases

COVID Tests i
() Femate 6758

Medications. i 5399

Procedures

Conditions.

(] Native Hawaian of oth,
(] Nt Report a5
(O other w
© 1more

Ethnicity a9
X ) cases
Hisparic or Latino w

@ NotHispanicorLatino. 12159
NotReported 604

() covip-19 Test 5458
st covo st 1215
o data 73

] cases
Qo a05
Qo 1
Qros '
o 2
Qovo o6
Oozs 1
© 138more
19 Posi a9
=) cases
0 2029

Imaging Series

Default Clear Al

Browse Data f,  Documentation Login 3]
@ o ®

COVID-19 Positive

Not Reportd

Submitter Id sex

10041569-6BdFk4phVEGO2F1hRYCOIQ  Female

10041569-BKd0sPORSK6OOCXIVKIOA  Female

10022779-807cnRmhEachFKuxlppg  Male

10022779-5K267FLAMUERIRrorpkIbQ  Male

639127-003983 Female

639127.002690 Female

10003752 XYEULM(72ke9a0jgKABRAQ  Female

639127-004339 Male
302028.000839 Female
232451-000459 Female

Age at Index

Index Event

First COVID test

First COVID test

First COVID test

First COVID test

First COVID test

First COVID fest

First COVID test
First COVID test

First COVID test

First COVID test

Race

Black or African American

Black or African American

Black or African American

Black or African American

Black or African American

Black or African American

Black or African American

Black or African American

Black or African American

Black or African American

Not Reported

Ethnicity

Not Hispanic or Latino

Not Hispanic or Latino

Not Hispanic or Latina

Not Hispanic or Latino

Not Hispanic or Latino

Not Hispanic or Latino

Not Hispanic or Latino

Not Hispanic or Latino

Not Hispanic or Latino

Not Hispanic or Latino

Race x

Native Hawailan Or Other Pactic I

American indian Or Alaska Natve ——
Other

Not Roporiod

Black Or Aftcan Amorican
Fomaln e

Covid19 Positive Test Name Test Results Text Test Me

Yes - > @ T
Yes OVID-1 ( rre
" (covip-r ovib. 19 [ neoarve T wecanve ] (_nrel
No Vi1 <= Crom
o = e
D TS ‘

Rowsperpage | 10 © | 1400f12150 KK < > >l



NextJS Application Framework GEN
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NextJS application server for Gen3 commons

Frontend module implements standard Gen3 Features
Supports access-controlled pages and page sections
Analysis tool registration with the ATF

Enables complex site navigation and middleware support



Site Configuration GEN
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e Builtinto @gen3/frontend

e Current support: file-based configurations

e Future: database-stored
configurations/introspection

e Separate configuration file for each
page/application

e Backward compatibility with data-portal but with
new capabilities

e Planned: Web-based configuration and validation
in the pipeline

e Planned: hybrid data-portal/Gen3FF

Data Portal

portal/gitops.json




Data-commons Web Application Framework GEN
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e Datacommon is a git repository: Gen3 Frontend Framework
o configuration - _ .
o icons
o custom code and pages
o content

e Addition pages can be added as NextJS
pages, slugs, or Markdown
e Registered Analysis Tools



Custom Content and Analysis Tools GEN
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Enable simple way to add commons-specific content
Addition of custom pages via React JSX or TSX
Markdown support

More complex pages:
o  Custom components
o Analysis tool built using React and Gen3 modules



Color Theming

GEN
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Color tokens based on USWDS:
e Primary
e Secondary
e Accent
[ J

Command line tool to create:
e 10 shades per color token
e 508 compliant contrasting
color

Color tokens are used exclusively
in Gen3 front end
components/pages

GENZ

Color Palettes

The following theme colors are are currently available in this Gen3 Data Commons.

base

primary

secondary

accent

accent-warm

accent-cool

chart

utility

@

\\\\\\\\

Workspace Profile

darkest

-

= ® 010101

Discovery Dictionary Exploration Query Analysis

max lightest lighter light ’ ‘ base ’ ‘ vivid ‘ ‘ dark ’ darker
max lightest lighter ‘ light ‘ ” |
= I

darkest

darkest

darkest

darkest

darkest

darkest

category3

. i i . 3 . 3 |
5 5i 5] 5 5]

min

min



Development Environment GEN
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e Local development using Gen3 Helm charts for Gen3 Services
e Commons site runs as a NextJS development server

e Support development features:
o hotreloading,
o debugging w/breakpoints
e Planto support debug commons
e Provide sample helm configurations and tools to run local development

environment



Status and Roadmap GEN
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Current:

e Discovery Page
Query Page
Login
Profile
Basic theming
Configuration

Styling and Theming

Features



Conclusion GEN
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Gen3 frontend framework overcomes current portal limitations
Enriched user experience

Easier development and deployment

Many options for customization

Facilitates complex data analysis workflows
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